upgrade





Donkey Server No. 1 Forces Upgrade

Over the past few days, more and more users were horrified that search results turned up nothing but the following: “please use emule 0.47c and enable protocol obfuscation to get results from this server.”